summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre Mavro2020-05-20 19:13:39 +0200
committerPierre Mavro2020-05-20 19:13:39 +0200
commit8474569b6bf89a6c18265046ebcb713a6d9e5184 (patch)
tree0e9e8bc381a9b3dcc587731215914be7b5f54a1b /PKGBUILD
downloadaur-8474569b6bf89a6c18265046ebcb713a6d9e5184.tar.gz
feat: jeedom status 0.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5509f3ba5e34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Pierre Mavro <deimosfr@gmail.com>
+pkgname=jeedom-status
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Add Jeedom global status to your favorite desktop bar (i3blocks, polybar, etc...)"
+arch=(x86_64)
+url="https://github.com/deimosfr/jeedom-status"
+license=('GPL')
+depends=()
+makedepends=(git go)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/deimosfr/jeedom-status/archive/v$pkgver.tar.gz")
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o jeedom-status main.go
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}