summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0xgingi2024-03-06 12:24:06 -0500
committer0xgingi2024-03-06 12:24:06 -0500
commit6bee1158a57bdfa9b2ae722f10a9ec9f9e7f4345 (patch)
tree074bde12e737e12d7e0132a2f44ed1fd62f002ed /PKGBUILD
parentd6d1ef7e8e44805e6cf48ac3c45ea4990b676157 (diff)
downloadaur-6bee1158a57bdfa9b2ae722f10a9ec9f9e7f4345.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 483009feb71c..5dc3597d2351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: 0xGingi <0xgingi@0xgingi.com>
pkgname=('jellyfin-rpc-git')
-pkgver=0.15.5.r4.gefc78b5
+pkgver=1.0.2.r0.g1163cfe
pkgrel=1
pkgdesc="Displays the content you're currently watching on Discord"
arch=('any')
@@ -12,6 +12,7 @@ provides=('jellyfin-rpc')
conflicts=('jellyfin-rpc')
source=("git+https://github.com/Radiicall/jellyfin-rpc.git")
md5sums=('SKIP')
+options=(!lto)
pkgver() {
cd jellyfin-rpc
@@ -30,13 +31,14 @@ build() {
cd jellyfin-rpc
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- cargo build --frozen --release --no-default-features
+ cargo build --frozen --release --all-features --no-default-features
+
}
check() {
cd jellyfin-rpc
export RUSTUP_TOOLCHAIN=stable
- cargo test --frozen --no-default-features
+ cargo test --frozen --all-features
}