summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-10 18:43:16 +0800
committerChocobo12023-04-10 18:43:16 +0800
commitf828bfe0761113b46fa2066c35a4bcb3a1762ad7 (patch)
treebe03b7b082620d367c4a5c022ae37bca550fea93 /PKGBUILD
parent0674fd82ca14841f00a30032fbedad3c573efc8d (diff)
downloadaur-jemalloc-git.tar.gz
upgpkg: jemalloc-git 5.3.0.r60.g5f64ad60-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5464e2cc720e..9cec7a13ff71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=jemalloc-git
-pkgver=5.0.1.r25.gea91dfa5
+pkgver=5.3.0.r60.g5f64ad60
pkgrel=1
pkgdesc="General purpose malloc implementation"
arch=('i686' 'x86_64')
-url="http://jemalloc.net/"
+url="https://jemalloc.net/"
license=('BSD')
depends=('glibc' 'sh')
makedepends=('git' 'docbook-xsl')
optdepends=('perl: for running jeprof')
-provides=('jemalloc')
+provides=("jemalloc=$pkgver")
conflicts=('jemalloc')
source=("git+https://github.com/jemalloc/jemalloc.git")
sha256sums=('SKIP')
@@ -26,7 +26,9 @@ build() {
cd "jemalloc"
_xslroot="/usr/share/xml/docbook/xsl-stylesheets-$(pacman -Q docbook-xsl | cut -d ' ' -f 2 | cut -d '-' -f 1)"
- ./autogen.sh --prefix="/usr" --with-xslroot="$_xslroot"
+ ./autogen.sh \
+ --prefix="/usr" \
+ --with-xslroot="$_xslroot"
make
}
@@ -41,7 +43,7 @@ package() {
make dist
make DESTDIR="$pkgdir" install
- install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/jemalloc/COPYING"
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/jemalloc"
find "$pkgdir" -name \*.a -type f -exec chmod 644 '{}' \;
}