summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrederik2016-05-25 11:45:09 +0200
committerfrederik2016-05-25 11:45:09 +0200
commitd1c944d40cba7e67db15a3022d11cfc40caf72be (patch)
treedfb0bea1a2fe661cb735247b0c0ebc1dc26bdd6f /PKGBUILD
downloadaur-d1c944d40cba7e67db15a3022d11cfc40caf72be.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..bcb4efbd5eca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
+
+pkgname=jetbrains-toolbox
+pkgver=1.0.1483
+pkgrel=1
+pkgdesc="Manage all your JetBrains Projects and Tools"
+arch=('x86_64' 'i686')
+options=('!strip')
+url="http://www.jetbrains.com/${pkgname}/"
+license=('Commercial')
+optdepends=('java-environment>=8: use system java'
+ 'java-runtime-common: use system java')
+source=(https://download.jetbrains.com/toolbox/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('a32e5eac8d7d769eca5b7cb0c83572db6193666818c7163913fed45988cd5346')
+
+package() {
+ install -d -m 755 ${pkgdir}/opt/${pkgname}
+ install -d -m 755 ${pkgdir}/usr/bin/
+
+ install -D -m 755 ${srcdir}/${pkgname}-${pkgver}/${pkgname} ${pkgdir}/opt/${pkgname}/${pkgname}
+
+ ln -s /opt/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+}