summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHarvey Tindall2023-06-24 12:04:37 +0100
committerHarvey Tindall2023-06-24 12:04:37 +0100
commitdd65e731e85fca074a5bf7d3ee6c699b0a05f43a (patch)
treefc83c36190bd00c47a61c1e64c9d81aaa61eee03 /PKGBUILD
parent2f91ce6f3af2fc96db5ddb510639d65d27bcea5f (diff)
downloadaur-dd65e731e85fca074a5bf7d3ee6c699b0a05f43a.tar.gz
update to support post-hiatus versions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b59927cbfd50..163c6c53dbf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Harvey Tindall <hrfee@protonmail.ch>
pkgname=jfa-go-git
_pkgname=jfa-go
-pkgver=r1118.a8daa2c
+pkgver=r1389.753f5fc
pkgrel=1
pkgdesc="A web app for managing users on Jellyfin"
arch=('x86_64' 'aarch64' 'armv6h' 'armv7h')
url="https://github.com/hrfee/jfa-go"
license=('MIT')
-makedepends=('go>=1.16' 'python>=3.6.0-1' 'nodejs' 'npm' 'git')
+makedepends=('go>=1.18' 'python>=3.6.0-1' 'nodejs' 'npm' 'git' 'esbuild')
checkdepends=()
optdepends=()
provides=("jfa-go")
@@ -29,17 +29,17 @@ pkgver() {
prepare() {
cd ${pkgname}
- make configuration npm email typescript GOESBUILD=off INTERNAL=OFF
- go get github.com/swaggo/swag/cmd/swag
+ make configuration npm email typescript GOESBUILD=on INTERNAL=off
+ go install github.com/swaggo/swag/cmd/swag@latest
}
build() {
cd ${pkgname}
export GOPATH="$(go env GOPATH)"
- make variants-html bundle-css inline-css GOESBUILD=off INTERNAL=off
+ make variants-html bundle-css inline-css GOESBUILD=on INTERNAL=off
"${GOPATH}"/bin/swag init -g main.go
make copy INTERNAL=off
- make compile INTERNAL=off
+ make compile INTERNAL=off BUILTBY="makepkg (aur)"
}
package() {
@@ -49,6 +49,7 @@ package() {
mkdir -p "$pkgdir"/usr/bin
chown -R root "$pkgdir"/opt/$_pkgname/
chmod 755 "$pkgdir"/opt/$_pkgname/$_pkgname
- ln -sf /opt/$_pkgname/$_pkgname "$pkgdir"/usr/bin/$_pkgname
+ ln -sf "$pkgdir"/opt/$_pkgname/$_pkgname "$pkgdir"/usr/bin/$_pkgname
+ install -Dm644 static/fonts/OFL.txt -t "$pkgdir"/usr/share/licenses/$_pkgname
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$_pkgname
}