summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHarvey Tindall2021-03-02 01:23:30 +0000
committerHarvey Tindall2021-03-02 01:23:30 +0000
commitf3b096d5e79701c9a41dd206bdea9a84dae61305 (patch)
tree458b7f386912ea402c5e27f6d191c5d2dc1a2289 /PKGBUILD
parentf76d82fb799c62121b00c18694efd24dd280b947 (diff)
downloadaur-f3b096d5e79701c9a41dd206bdea9a84dae61305.tar.gz
use go esbuild for support on arm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d508e739976f..bec3f25e857a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=jfa-go-git
_pkgname=jfa-go
pkgver=r495.bd05a4b
-pkgrel=1
+pkgrel=2
pkgdesc="A web app for managing users on Jellyfin"
-arch=("x86_64")
+arch=('x86_64' 'aarch64' 'armv6h' 'armv7h')
url="https://github.com/hrfee/jfa-go"
license=('MIT')
makedepends=('go>=1.16' 'python>=3.6.0-1' 'nodejs' 'npm' 'git')
@@ -29,14 +29,14 @@ pkgver() {
prepare() {
cd ${pkgname}
- make configuration npm email
+ make configuration npm email GOESBUILD=on
go get github.com/swaggo/swag/cmd/swag
}
build() {
cd ${pkgname}
export GOPATH="$(go env GOPATH)"
- make typescript bundle-css
+ make typescript bundle-css GOESBUILD=on
"${GOPATH}"/bin/swag init -g main.go
make copy external-files compile
}