summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpurpleleaf2022-03-08 00:09:37 +0100
committerpurpleleaf2022-03-08 00:09:37 +0100
commit9008139f803fa1b09daad70d77679ab6db3e4616 (patch)
tree79c3af9378f21f44e27802357318351e0c10d884 /PKGBUILD
parent0b8c7559b6dece207d66d0e046a7ba974d7e205f (diff)
downloadaur-9008139f803fa1b09daad70d77679ab6db3e4616.tar.gz
Second Release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ee179622fd8..7b02468aee37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: purpleleaf <max@ganoia.eu>
_pkgname=jgmenu
pkgname=$_pkgname-git
-pkgver=`git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's:^v::'`
-pkgrel=1
+pkgver=v4.4.0
+pkgrel=2
pkgdesc="Simple, independent, contemporary-looking X11 menu, designed for scripting, ricing and tweaking. Compiled with gtktheme, lx and pmenu support"
arch=('x86_64')
url="https://github.com/johanmalm/$_pkgname"
@@ -14,8 +14,10 @@ source=("${_pkgname}::git+${url}.git")
sha256sums=("SKIP")
pkgver() {
- cd ${pkgname}
- echo $pkgver
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}