summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpurpleleaf2022-04-04 13:34:30 +0200
committerpurpleleaf2022-04-04 13:34:30 +0200
commitb413fc1b243811554e85b4da9415801f1d6bc425 (patch)
treeeaa1b75dafa18d908a0c42191d7a6212316f59e9 /PKGBUILD
parentd29018b015d0245027e793314d6cbc836b9570c8 (diff)
downloadaur-b413fc1b243811554e85b4da9415801f1d6bc425.tar.gz
Modifiche basate su PKGBUILD di s3rj1k <evasive dot gyron at gmail dot com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1cfbcc079666..132872630198 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,10 @@
# Maintainer: purpleleaf <max@ganoia.eu>
+# Do not forget to run `makepkg --printsrcinfo > .SRCINFO`
-pkgname=jgmenu-git
-pkgver=4.4.0.r1.gc258a6c
+_pkgname=jgmenu
+_pkgver=4.4.0
+pkgname=${_pkgname}-git
+pkgver=4.4.0
pkgrel=1
pkgdesc="Simple, independent, contemporary-looking X11 menu, designed for scripting, ricing and tweaking. Compiled with gtktheme, lx and pmenu support"
arch=('x86_64')
@@ -9,18 +12,18 @@ url="https://jgmenu.github.io/"
license=('GPL2')
depends=('libx11' 'cairo' 'pango' 'libxrandr' 'librsvg' 'libxml2' 'glib2' 'menu-cache' 'python')
makedepends=(git)
-provides=(jgmenu)
-conflicts=(jgmenu)
+provides=(${_pkgname})
+conflicts=(${_pkgname})
source=("git+https://github.com/johanmalm/jgmenu.git")
sha256sums=("SKIP")
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${srcdir}/${_pkgname}"
+ printf "%s+%s" "${_pkgver}" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${srcdir}/${_pkgname}"
./configure \
--with-gtktheme \
--with-lx \