summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-09-09 00:16:44 +0100
committerWorMzy Tykashi2015-09-09 00:16:44 +0100
commitcffbade687314d540c4255c08d8f571429ac8648 (patch)
treea25ee54d501c5c0096872160b6fd2e46c65b87da /PKGBUILD
downloadaur-cffbade687314d540c4255c08d8f571429ac8648.tar.gz
Re-uploaded to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb20c483e48d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: <qqqqqqqqq9 at web dot de>
+# Contributor: yannsen <ynnsen at gmail dot com>
+pkgname=jnc
+pkgver=0.19
+pkgrel=1
+pkgdesc="A wrapper for the Juniper network connect client (ncsvc)"
+arch=('any')
+url="http://www.scc.kit.edu/scc/net/juniper-vpn/linux/"
+license=('GPL')
+depends=('perl' 'openssl' 'net-tools')
+[[ $CARCH == "x86_64" ]] && depends=('perl' 'openssl' 'net-tools' 'lib32-nss-mdns' 'lib32-zlib')
+makedepends=()
+optdepends=('java: for Network Connect Java GUI, with x86_64 the Network Connect Java GUI will not work')
+source=(http://www.scc.kit.edu/scc/net/juniper-vpn/linux/$pkgname)
+install=jnc.install
+sha256sums=('5eb2f187a32c009ca4e19042ee46e6a1b99a0ec0714b0b93f207b11440ff4fb7')
+
+package() {
+ install -d $pkgdir/usr/bin/
+ install -m755 jnc $pkgdir/usr/bin/
+}
+