summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2020-01-05 09:49:42 -0500
committerDavid Parrish2020-03-12 16:16:50 -0400
commit5c8dda14b57358ecd684bd91839ef63f4d58c798 (patch)
tree57f4721ee2be79f37d4b80b444177961f4eb82d6 /PKGBUILD
downloadaur-5c8dda14b57358ecd684bd91839ef63f4d58c798.tar.gz
Initial commit
Installs joinmarket scripts and dependencies, but is missing launcher or support for non root users due to hard coded data directory
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba20c41120b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+# shellcheck disable=SC2034,SC2164
+
+pkgname=joinmarket-qt-git
+pkgver=0.6.1.r91.ga050a89
+pkgrel=1
+pkgdesc="Coinjoin software, includes a QT wallet and requires Bitcoin Core as backend"
+arch=('any')
+depends=( 'python-pyqt5' 'pyside2' 'python-qt5reactor'
+ 'python-jmbase-git' 'python-jmclient-git' 'python-jmbitcoin-git' 'python-jmdaemon-git'
+ )
+makedepends=('git' 'python-setuptools')
+url="https://github.com/JoinMarket-Org/joinmarket-clientserver"
+license=('GPL3')
+source=("$pkgname::git+https://github.com/JoinMarket-Org/joinmarket-clientserver.git"
+ "joinmarket-qt")
+sha256sums=('SKIP'
+ 'f97ea99c2d74db9b966213206925464f2a9a83ab75937e922b206559fa89486d')
+options=(!strip)
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+# GUI and other scripts
+package_joinmarket-qt-git() {
+ depends+=( 'python-pyqt5' 'pyside2' 'python-qt5reactor'
+ 'python-jmbase-git' 'python-jmclient-git' 'python-jmbitcoin-git' 'python-jmdaemon-git'
+ )
+
+ # Dump scripts into /opt/joinmarket
+ mkdir -p "${pkgdir:?}/opt/$pkgname"
+ cp -r "${srcdir:?}/${pkgname}/scripts/"* "${pkgdir}/opt/$pkgname"
+
+ # Use entrypoint script to manage getting joinmarket-qt started
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$srcdir/joinmarket-qt" "$pkgdir/usr/bin"
+}