summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2015-09-16 10:33:35 -0400
committerChris Severance2015-09-16 10:33:35 -0400
commit7bd2e91d9d261c55e6a4231a40eac4952ac4079e (patch)
tree4908823ae18737deab03bbfe1cab7a20b6347ab3 /PKGBUILD
downloadaur-7bd2e91d9d261c55e6a4231a40eac4952ac4079e.tar.gz
Initial Import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06610481a9f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: /dev/rs0 <rs0@secretco.de.com>
+
+set -u
+pkgname='joomscan'
+pkgver='2012_03_10'
+pkgrel='1'
+pkgdesc='Detects file inclusion, sql injection, command execution vulnerabilities of a target Joomla! web site.'
+arch=('any')
+url="http://${pkgname}.sourceforge.net/"
+license=('LGPL3')
+
+depends=('perl-switch' 'perl-www-mechanize')
+makedepends=('unzip')
+
+_srcdir="${pkgname}-${pkgver}"
+source=(
+ 'joomscan.sh'
+ "http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver//_/-}/${pkgname}-latest.zip"
+)
+noextract=("${source[1]##*/}")
+sha256sums=('67de695ba7db7ef5864bd0c888dc9578de6a7139d4286ed4bc6ba42a486cda32'
+ '7edbcf069fe60b032cd273d06de1f8c40459c65ae8e604602e8f60150f08ec6e')
+
+prepare() {
+ set -u
+ unzip -oaq -d "${_srcdir%%/*}" "${source[1]##*/}"
+ set +u
+}
+
+package() {
+ set -u
+ cd "${_srcdir}"
+ install -Dpm0755 "${pkgname}.pl" "${srcdir}/${pkgname}.sh" -t "${pkgdir}/usr/share/${pkgname}/"
+ install -Dpm0644 "${pkgname}"{db,db-info}.txt -t "${pkgdir}/usr/share/${pkgname}"
+
+ mv 'report' "${pkgdir}/usr/share/${pkgname}"
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ mv 'doc'/* "${pkgdir}/usr/share/doc/${pkgname}"
+
+ install -d "${pkgdir}/usr/bin"
+ ln -sf "/usr/share/${pkgname}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ install -d "${pkgdir}/usr/share/${pkgname}/doc"
+ touch "${pkgdir}/usr/share/${pkgname}/doc/AGREEMENT"
+ set +u
+}
+set +u