summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKimiblock Moe2024-03-23 15:16:18 +0800
committerKimiblock Moe2024-03-23 15:16:18 +0800
commit9ab9e7c272e55df8535055295a0c6d4b6710200e (patch)
tree88fb4b614ebb077c343ada87ca0d01423ee5a148 /PKGBUILD
parentf2ab2aaef4bd89124fd12be13635afb0778329b3 (diff)
downloadaur-9ab9e7c272e55df8535055295a0c6d4b6710200e.tar.gz
Revert "Add missing dep"
This reverts commit f2ab2aaef4bd89124fd12be13635afb0778329b3.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ceb42f4fbe3..7c56ae39e5c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=(any)
pkgver=r18.958a175
pkgrel=1
makedepends=(python-setuptools git)
-depends=(python python-xxhash python-yaml python-matrix-nio)
+depends=(python python-xxhash python-yaml)
optdepends=(postgresql-libs)
source=(
"git+https://github.com/ShadowRZ/jose-bot.git"
@@ -20,7 +20,7 @@ provides=(jose-bot)
function pkgver() {
cd "${srcdir}/jose-bot"
- git describe --long --tags --abbrev=8 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
function build() {