summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormirandir2015-06-08 12:16:05 +0200
committermirandir2015-06-08 12:16:05 +0200
commit357ba36c5ce4048404cb2368d7420631e2b3be76 (patch)
tree2d528c7f40f0f432b0c1a99d8828ca793ac74d66 /PKGBUILD
downloadaur-357ba36c5ce4048404cb2368d7420631e2b3be76.tar.gz
AUR4 import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab619da57c1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: mirandir <mirandir@orange.fr>
+
+pkgname=joystickwake-git
+_realname=joystickwake
+pkgver=e55e11f
+pkgrel=1
+pkgdesc="Joystick-aware screen waker. This program attempts to prevent screen blankers from activating while joysticks and other game controllers are in use."
+arch=('any')
+url=('https://github.com/foresto/joystickwake')
+license=('MIT')
+depends=('python-pyudev' 'python3-xlib')
+makedepends=('git' 'python-docutils' 'gzip')
+source=(joystickwake::git+https://github.com/foresto/joystickwake)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_realname}"
+ git describe --always | sed 's|-|.|g'
+}
+
+package() {
+ cd $srcdir/$_realname
+ python setup.py install --prefix=/usr --root=$pkgdir
+ # manpage
+ install -d $pkgdir/usr/share/man/man1
+ rst2man README.rst joystickwake.1
+ gzip joystickwake.1
+ mv joystickwake.1.gz $pkgdir/usr/share/man/man1
+}
+