summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaptiste Lartigau2018-05-04 14:34:59 +0200
committerBaptiste Lartigau2018-05-04 14:39:42 +0200
commit0aa3a29ee56cc138ad4262b236bd1fe8bef1bf8d (patch)
treeead890863b63dc20e8b4f380f7a0199a67fc2169 /PKGBUILD
downloadaur-0aa3a29ee56cc138ad4262b236bd1fe8bef1bf8d.tar.gz
Initial commit
This package aims to provide a way to install jpf from the binary snapshots hosted on the project's website. Due to a few deprecations in recent versions of Java 8, building the sources have become impossible on some Linux setups, and this package has been created to get around this issue.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4053debab2cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Baplar <baplar@gmail.com>
+# Contributor: Drew Noel <drewmnoel@gmail.com>
+pkgname=jpf-core-bin
+pkgver=r32
+pkgrel=1
+pkgdesc="An extensible software model checking framework for Java bytecode programs"
+arch=('any')
+url="https://babelfish.arc.nasa.gov/trac/jpf/wiki/projects/jpf-core"
+license=('APACHE')
+depends=('java-environment-openjdk>=8')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=('https://babelfish.arc.nasa.gov/trac/jpf/raw-attachment/wiki/projects/jpf-core/jpf-core-r32.zip'
+ 'jpf'
+ 'jpf.properties')
+md5sums=('a9a3cff397180a533a93fd434241a225'
+ '85a27d09ee9ec6137d5f7c43180c87e0'
+ '31708844142d0b48a3227b113db0cb0f')
+
+JPF_HOME=/usr/share/java/jpf
+BIN_DIR=/usr/local/bin
+
+package() {
+ cd $srcdir
+
+ # Copy the mandatory config
+ install -D -m644 -t $pkgdir/$JPF_HOME/ jpf.properties
+
+ # Copy all the .JAR files
+ install -D -m644 -t $pkgdir/$JPF_HOME/ jpf-core/build/*.jar
+
+ # Copy the jpf executable
+ install -D -m755 -t $pkgdir/$BIN_DIR/ jpf
+}