summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTucker Boniface2018-08-30 22:47:46 -0700
committerTucker Boniface2018-08-30 22:47:46 -0700
commit31ac9454df9d5f51537555ddf4531d845ae1c4bf (patch)
tree97ca1ef4d6d3a7c121eae229d11ebf1dbfb7550b /PKGBUILD
parent78255ecab0c254ea054b9bb0120d191ba656ef9f (diff)
downloadaur-31ac9454df9d5f51537555ddf4531d845ae1c4bf.tar.gz
apply patch to fix compilation
https://github.com/stedolan/jq/pull/1702
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a27bcef023b..bf1c3e915db7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=jq-git
_gitname='jq'
-pkgver=1.6rc2
-pkgrel=1
+pkgver=1.6rc2.2.g341a5fc
+pkgrel=2
pkgdesc='Command-line JSON processor'
arch=('i686' 'x86_64')
url='http://stedolan.github.io/jq/'
@@ -14,14 +14,20 @@ depends=('oniguruma')
makedepends=('python2' 'git' 'autoconf' 'automake' 'bison' 'flex' 'glibc')
provides=('jq')
conflicts=('jq')
-source=('git+https://github.com/stedolan/jq.git')
-md5sums=(SKIP)
+source=('git+https://github.com/stedolan/jq.git'
+ '0001-Bugfix-Math-function-checking.patch::https://github.com/stedolan/jq/pull/1702.patch')
+sha512sums=('SKIP'
+ '4f092cfc4a3fb8ba25d322fe5dbdf165e1309cc3cc2789b1f337e1c5bd70e7ba7ae372ffa71a11775d4b6551faa6e172db5bd3bc9cf38eeeb4625c667d659b0c')
pkgver() {
cd "$_gitname"
git describe --tag | sed -e 's/^jq-//' -e 's/-/./g'
}
+prepare() {
+ cd "$_gitname"
+ patch -p1 < "$srcdir"/0001-Bugfix-Math-function-checking.patch
+}
build() {
cd "$_gitname"