summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorblackhole2018-04-14 09:34:40 +0200
committerblackhole2018-04-14 09:34:40 +0200
commitd8535e5db2895d1bb20777f7c3952834e909821b (patch)
treeeeb47c0c72f646eabc70d0d4f2e50fa35eb07171 /PKGBUILD
downloadaur-d8535e5db2895d1bb20777f7c3952834e909821b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ef1665e2671
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
+
+pkgname=jriver-media-center24
+_debpkgver=24.0.15
+pkgver=24.0.15
+pkgrel=1
+pkgdesc="The Most Comprehensive Media Software"
+arch=('x86_64')
+url="http://www.jriver.com/"
+license=('custom')
+depends=('alsa-lib' 'gcc-libs' 'libx11' 'libxext' 'libxcb' 'libxau' 'libxdmcp' 'util-linux' 'libxext' 'gtk2')
+optdepends=('mesa-libgl: nouveau video support' 'nvidia-libgl: nvidia video support' 'vorbis-tools' 'musepack-tools')
+conflicts=('jriver-media-center')
+source=("http://files.jriver.com/mediacenter/channels/v24/latest/MediaCenter-$_debpkgver-amd64.deb" 'License.txt')
+sha256sums=('SKIP' 'ee00f430918df6be37777a61e12812875b5583379c78daaa969bae7383a41fbd')
+
+package() {
+ cd "$srcdir"
+ bsdtar xf data.tar.xz -C "$pkgdir"
+ install -Dm644 "License.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}