summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrice Peterson2015-08-20 15:15:36 +0200
committerPatrice Peterson2015-08-20 15:15:36 +0200
commit29a45e2c7a9616d4fd8ba98628cd256b61b32361 (patch)
tree3afe3613ba4ee40e55bb39229cdf878329b3aafa /PKGBUILD
downloadaur-29a45e2c7a9616d4fd8ba98628cd256b61b32361.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0129c93d8167
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Patrice Peterson <runiq at archlinux dot us>
+
+pkgname=jrnl
+pkgver=1.9.8
+pkgrel=1
+pkgdesc="A simple command line journal application that stores your journal in a plain text file"
+arch=('any')
+url="https://maebert.github.io/jrnl"
+license=('MIT')
+depends=('python-parsedatetime>=1.2'
+ 'python-pytz>=2013b'
+ 'python-six>=1.6.1'
+ 'python-tzlocal>=1.1'
+ 'python-keyring>=3.3'
+ 'python-dateutil>=2.2')
+optdepends=('python-crypto: AES256-encrypted journal')
+source=("https://pypi.python.org/packages/source/j/$pkgname/$pkgname-${pkgver}.tar.gz")
+sha256sums=('d254c9c8f24dcf985b98a1d5311337c7f416e6305107eec34c567f58c95b06f4')
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: