summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Palenzuela2019-10-06 11:46:32 +0100
committerManuel Palenzuela2019-10-06 11:46:32 +0100
commitb00fd527bf895d46b7cbaddfdbc6348a5fac7b33 (patch)
treeeea289d4fad3b84c1cbb4e1e25368dff314b0fd9 /PKGBUILD
parent13de0cd5d6bbbef3358a8b9f1248be69ede96c0b (diff)
downloadaur-b00fd527bf895d46b7cbaddfdbc6348a5fac7b33.tar.gz
Updated install functioN
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69f342c5009b..1696233de8ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,14 @@
pkgname=jrnl-git
_gitname=jrnl
-pkgver=0
+pkgver=0.r775.350f0a1
pkgrel=1
pkgdesc="A simple command line journal application that stores your journal in a plain text file"
arch=('any')
url="https://jrnl.sh/"
license=('MIT')
-depends=('python-asteval' 'python-dateutil' 'python-keyring' 'python-keyrings-alt' 'python-parsedatetime' \
- 'python-pytz' 'python-tzlocal' 'python-pyaml' 'python-six' 'python-passlib' 'python-xdg' 'python-cryptography')
-makedepends=('git')
+depends=('python')
+makedepends=('git' 'poetry')
conflicts=("jrnl")
source=("git+https://github.com/maebert/jrnl.git")
@@ -25,7 +24,12 @@ pkgver() {
}
package() {
- cd "$_gitname/$_gitname"
- python install.py --root="$pkgdir/" --optimize=1
+ cd "$_gitname"
+ make install
install -D LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ mkdir -p $pkgdir/usr/bin/
+ touch $pkgdir/usr/bin/jrnl
+ echo "$HOME/.cache/pypoetry/virtualenvs/jrnl*/bin/jrnl" > $pkgdir/usr/bin/jrnl
+ chmod +x $pkgdir/usr/bin/jrnl
}