summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-05-21 11:52:46 +1200
committercaltlgin2020-05-21 11:52:46 +1200
commit4449c11468553c54cafdd0b34bf8e3041c48e8b1 (patch)
treeaece0288e12d9b6de8151e1821cc20a113995b44 /PKGBUILD
downloadaur-4449c11468553c54cafdd0b34bf8e3041c48e8b1.tar.gz
Add to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67cb47427e45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname=json2tsv
+pkgver=0.5
+pkgrel=1
+pkgdesc="JSON to TSV converter"
+arch=('x86_64')
+url="https://codemadness.org/json2tsv.html"
+license=('custom:ISC license')
+source=("https://codemadness.org/releases/json2tsv/json2tsv-${pkgver}.tar.gz")
+depends=('glibc')
+makedepends=('gcc-libs')
+provides=('json2tsv')
+conflicts=('json2tsv')
+sha256sums=('0e919ff3ecd4eed8d1209e1da0bb6d4c4099b276168a941b8bceecfe128e1fc5')
+
+build() {
+ cd "json2tsv-${pkgver}"
+ make
+}
+
+package() {
+ cd "json2tsv-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX="/usr" MANPREFIX="/usr/share/man" install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file