summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-10-25 11:54:13 +1300
committercaltlgin2020-10-25 11:54:13 +1300
commit8434e74239b767cb886f755c3de1509b4759e2d2 (patch)
tree686a5536f5425a441ae5c6c70ccb1d5b87464314 /PKGBUILD
parentb2717f72aeee4a0315fd1ddb308b98f7ecd871d7 (diff)
downloadaur-8434e74239b767cb886f755c3de1509b4759e2d2.tar.gz
Refactored PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 591ce3871fc3..4941c0c4c202 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname=json2tsv
+pkgname='json2tsv'
pkgver=0.5
pkgrel=2
pkgdesc='JSON to TSV converter'
arch=('x86_64')
url='https://codemadness.org/json2tsv.html'
+_url_source='https://codemadness.org/releases/json2tsv'
license=('ISC')
-source=("https://codemadness.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+source=("${_url_source}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('0e919ff3ecd4eed8d1209e1da0bb6d4c4099b276168a941b8bceecfe128e1fc5')
build() {
@@ -15,8 +16,8 @@ build() {
}
package() {
- make DESTDIR="${pkgdir}" PREFIX="/usr" MANPREFIX="/usr/share/man" -C "${pkgname}-${pkgver}" install
- install -Dm644 "${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make DESTDIR="${pkgdir}" PREFIX='/usr' MANPREFIX='/usr/share/man' -C "${pkgname}-${pkgver}" install
+ install -Dvm644 "${pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-# vim: ts=2 sw=2 et: \ No newline at end of file
+# vim: ts=2 sw=2 et: