summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2021-07-11 16:51:08 +1000
committerMatthew Gamble2021-07-11 16:51:08 +1000
commit0748105084e21c5549b2186b2fdaedc13a7bede1 (patch)
tree8a2a7a474f2f401342d4458555417104ae8e7748 /PKGBUILD
parent5c569ae646d73e210dd7947016e9c12a203e19d4 (diff)
downloadaur-0748105084e21c5549b2186b2fdaedc13a7bede1.tar.gz
Cleanup. Make build reproducible.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 21 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e1254239782..be735902e59e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname='jtbl'
+pkgname=jtbl
pkgver=1.1.6
pkgrel=2
pkgdesc='Simple cli tool to print JSON and JSON Lines data as a table in the terminal'
-arch=('any')
-url='https://github.com/kellyjonbrazil/jtbl'
-_url_pypi='https://pypi.org/project/jtbl'
-license=('MIT')
-depends=('python-tabulate')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('3623d4942b80bbd9f64c2f672c52862dad7e0d1245094a2416f04a09773b8660')
+arch=("any")
+url="https://github.com/kellyjonbrazil/jtbl"
+license=("MIT")
+depends=("python" "python-tabulate")
+makedepends=("python-setuptools")
+source=("https://files.pythonhosted.org/packages/source/j/jtbl/jtbl-${pkgver}.tar.gz")
+sha256sums=("3623d4942b80bbd9f64c2f672c52862dad7e0d1245094a2416f04a09773b8660")
build() {
- cd "${pkgname}-${pkgver}"
- python setup.py build
+ cd "jtbl-${pkgver}"
+
+ python setup.py build
}
package() {
- cd "${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
-}
+ cd "jtbl-${pkgver}"
-# vim: ts=2 sw=2 et:
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/jtbl/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/jtbl/README.md"
+
+ # https://github.com/kellyjonbrazil/jtbl/issues/5
+ #install -Dm644 CHANGELOG "${pkgdir}/usr/share/doc/jtbl/CHANGELOG"
+}