summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2022-01-23 23:08:03 +1100
committerMatthew Gamble2022-01-23 23:08:03 +1100
commit082524871fa8134a802d3164c20ba526a40cbcc9 (patch)
tree2094c0af89805c994b12da2f1cb15e54913556d5 /PKGBUILD
parent1b8f561038f3a5d3f62cad216f114fd60bcdda70 (diff)
downloadaur-082524871fa8134a802d3164c20ba526a40cbcc9.tar.gz
Update to latest release - v1.2.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dbfba24f4fe..b12090965fde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
pkgname=jtbl
-pkgver=1.1.7
+pkgver=1.2.3
pkgrel=1
-pkgdesc='Simple cli tool to print JSON and JSON Lines data as a table in the terminal'
+pkgdesc="A simple CLI tool to print JSON and JSON Lines data as a table in the terminal"
arch=("any")
url="https://github.com/kellyjonbrazil/jtbl"
license=("MIT")
depends=("python" "python-tabulate")
makedepends=("python-setuptools")
-source=("https://files.pythonhosted.org/packages/source/j/jtbl/jtbl-${pkgver}.tar.gz")
-sha256sums=("816aae6d72dac92c83273b5d693e8a32fccd696cf36e1f7fac2985dd72cf152e")
+source=("https://pypi.io/packages/source/j/jtbl/jtbl-${pkgver}.tar.gz")
+sha256sums=("1bc8d08a75cc584de4e13311e422bbdbec7b9334766cf2725d6862a1463ffa22")
build() {
cd "jtbl-${pkgver}"
@@ -23,8 +23,8 @@ package() {
cd "jtbl-${pkgver}"
PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/jtbl/LICENSE"
install -Dm644 README.md "${pkgdir}/usr/share/doc/jtbl/README.md"
-
install -Dm644 CHANGELOG "${pkgdir}/usr/share/doc/jtbl/CHANGELOG"
}