summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJiri Tyr2016-03-20 02:32:51 +0000
committerJiri Tyr2016-03-20 02:34:34 +0000
commit7f6b1691aebb96bc73d50aca1e90c5dfe973d377 (patch)
tree410617602e6baa53c2701692ab52090346f354a5 /PKGBUILD
downloadaur-jtyr-oh-my-zsh-theme-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7129c9d03665
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: TheAifam5 <aifam96 at gmail dot com>
+
+pkgname=jtyr-oh-my-zsh-theme-git
+pkgver=r2.12164f2
+pkgrel=1
+pkgdesc='A jtyr oh-my-zsh shell theme'
+arch=('any')
+url='https://gist.github.com/jtyr/97f05d4ce1e027094ae7'
+license=('MIT')
+depends=('zsh' 'oh-my-zsh-git')
+source=('git+https://gist.github.com/97f05d4ce1e027094ae7.git')
+sha256sums=('SKIP')
+makedepends=('git')
+
+pkgver() {
+ cd 97f05d4ce1e027094ae7
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd 97f05d4ce1e027094ae7
+
+ # Install the theme
+ install -D -m644 jtyr.zsh-theme "${pkgdir}/usr/share/oh-my-zsh/themes/jtyr.zsh-theme"
+}
+
+# vim:set ts=4 sw=4 et: