summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorarchshift2015-12-20 00:23:57 -0800
committerarchshift2015-12-20 00:23:57 -0800
commit31c510bc2886f566b4ba36d3d4a8df602ce7aec4 (patch)
tree8ca7bb1d06f359c9210874b8884cb42f89885071 /PKGBUILD
parent26534d68fd17612dcb4693e3ef1b628c6d19caf8 (diff)
downloadaur-31c510bc2886f566b4ba36d3d4a8df602ce7aec4.tar.gz
Correctly separated out submodules into sources, SHA1Sum'd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c70f96e04f43..c600ada6d807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,11 @@ license=('MIT')
depends=('gtksourceviewmm' 'clang' 'aspell')
makedepends=('git' 'cmake' 'pkg-config' 'boost')
-source=("$_pkgbase::git+https://github.com/cppit/jucipp.git" "CMakeLists.patch")
-sha1sums=('SKIP' 'SKIP')
+source=("$_pkgbase::git+https://github.com/cppit/jucipp.git"
+ "git+https://github.com/cppit/libclangmm.git"
+ "git+https://github.com/eidheim/tiny-process-library"
+ "CMakeLists.patch")
+sha1sums=('SKIP' 'SKIP' 'SKIP' '64ac5afbe9a3a8b92cc3001897529834cda501a5')
pkgver() {
cd "$srcdir/$_pkgbase"
@@ -23,7 +26,11 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgbase"
- git submodule update --init
+
+ git submodule init
+ git config submodule.libclangmm.url "$srcdir/libclangmm"
+ git config submodule.tiny-process-library.url "$srcdir/tiny-process-library"
+ git submodule update
git apply "$srcdir/CMakeLists.patch"
mkdir -p build