summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreidheim2018-06-16 07:47:00 +0200
committereidheim2018-06-16 07:47:00 +0200
commitca2c1b33e52720c945e5c830c01121a45467b83d (patch)
tree054652b2c6d8d3ec7388b27f690f2bd4ab9588e8 /PKGBUILD
parent27383d9283cd1a1ebf625716d9537d0d20aa605c (diff)
downloadaur-ca2c1b33e52720c945e5c830c01121a45467b83d.tar.gz
Corrected url and sources now that juCi++ and its support libraries have moved to GitLab. Also added aspell-en, the default dictionary, as dependency.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f8f7c5b9379..af051eccd51e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@ _pkgbase=jucipp
pkgbase=$_pkgbase-git
pkgname=("$_pkgbase-git")
pkgdesc='A lightweight platform-independent C++ IDE'
-pkgver=r1629.0406b7c
+pkgver=r2120.7d53bca
pkgrel=1
arch=('i686' 'x86_64')
-url="https://github.com/cppit/jucipp"
+url="https://gitlab.com/cppit/jucipp"
license=('MIT')
-depends=('gtksourceviewmm' 'clang' 'aspell' 'lldb' 'boost-libs' 'libgit2' 'ctags')
+depends=('gtksourceviewmm' 'clang' 'aspell-en' 'lldb' 'boost-libs' 'libgit2' 'ctags')
makedepends=('git' 'cmake' 'pkg-config' 'boost')
-source=("$_pkgbase::git+https://github.com/cppit/jucipp.git"
- "git+https://github.com/cppit/libclangmm.git"
- "git+https://github.com/eidheim/tiny-process-library")
+source=("$_pkgbase::git+https://gitlab.com/cppit/jucipp.git"
+ "git+https://gitlab.com/cppit/libclangmm.git"
+ "git+https://gitlab.com/eidheim/tiny-process-library")
sha1sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
@@ -27,8 +27,8 @@ prepare() {
cd "$srcdir/$_pkgbase"
git submodule init
- git config submodule.libclangmm.url "$srcdir/libclangmm"
- git config submodule.tiny-process-library.url "$srcdir/tiny-process-library"
+ git config submodule.libclangmm.url "$srcdir/lib/libclangmm"
+ git config submodule.tiny-process-library.url "$srcdir/lib/tiny-process-library"
git submodule update
mkdir -p build