summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathon Fernyhough2019-08-09 16:52:42 +0100
committerJonathon Fernyhough2019-08-09 16:52:42 +0100
commit4dd090bb55cf5b4b716b9ccb361a891220846abb (patch)
tree7dd3434d1bc818c8bdcacbf62219741a0a97dd31 /PKGBUILD
parent0e59f75ee5b04f2c5f3c9bdb3257b63ca9b3280a (diff)
downloadaur-4dd090bb55cf5b4b716b9ccb361a891220846abb.tar.gz
Upstream 0.17.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56b131ba3c41..cdbf4ad037bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=julia-datastructures
_pkgname=DataStructures
-pkgver=0.15.0
-pkgrel=2
+pkgver=0.17.0
+pkgrel=1
pkgdesc='Julia implementation of Data structures'
arch=(any)
url=https://github.com/JuliaCollections/DataStructures.jl
@@ -15,15 +15,15 @@ depends=(julia
) # julia-primes) circular dependency for check()
makedepends=(julia-distrohelper)
-_commit=8a0711a36f83df30c8cc7c8ff240a58fbbd85570
-source=($pkgname-$pkgver.tar.gz::https://github.com/JuliaCollections/$_pkgname.jl/archive/v$pkgver.tar.gz
+_commit=cb1789de11e6e5fa59d7380c99824fedf204d5ef
+source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
$pkgname-$pkgver-Deps.toml::https://raw.githubusercontent.com/JuliaRegistries/General/$_commit/${_pkgname:0:1}/$_pkgname/Deps.toml
$pkgname-$pkgver-Package.toml::https://raw.githubusercontent.com/JuliaRegistries/General/$_commit/${_pkgname:0:1}/$_pkgname/Package.toml
$pkgname-$pkgver-Versions.toml::https://raw.githubusercontent.com/JuliaRegistries/General/$_commit/${_pkgname:0:1}/$_pkgname/Versions.toml)
-sha256sums=('583bee9fc22880142298af535f979c599650c064f65ac5c6fa4b45d858919a9b'
- '0e09241d161b507e6568c3a736ae3635b95def76be5f97ea5795f9c59743b5b0'
+sha256sums=('b5c633571407bbd16b9fa229246bf0d57f43c0279fd5fa169a6b6f0bbbd948f3'
+ 'cecdff8d42dd008af9df6e584e8e93d1d308eb94c5672454359ac6d32093a231'
'7f7668d5864d661e32aa75e5ef6e9de218e160ec849b67d7555e66a48b2aa4e9'
- '98320b421d24300aba70a8e1716f2a47fad2a8a079378717450f1b2c17eeaa59')
+ 'aae3c2136dc1b186e58bf84ef557078dba48b564cc3006bd0f2c046864e52e4d')
_slug() {
dh_julia slug "$srcdir"/"$pkgname"-$pkgver-{Package,Versions}.toml