summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantinos2017-05-19 19:37:04 +0300
committerKonstantinos2017-05-19 19:37:04 +0300
commitbb634859260c5510ef7714b1eab5ae014623bdd2 (patch)
tree3e701e104a15ee77a9f9469197564e24fb5d7b80 /PKGBUILD
parent2bcf56abdc27dddd433ccd32c70ecb63383863f9 (diff)
downloadaur-jumanji-git.tar.gz
project is deprecated but still works fine; minus security issues because of WebKitGTK
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 22 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec91dd48c990..27df2d239e73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,35 @@
-# Maintainer: Moritz Lipp <mlq@pwmt.org>
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+# Contributor: Moritz Lipp <mlq@pwmt.org>
-pkgname=jumanji-git
-pkgver=r466.de4c6c3
+_pkgname=jumanji
+pkgname=${_pkgname}-git
+pkgver=r468.6f45380
pkgrel=1
-pkgdesc="a web browser"
-arch=('i686' 'x86_64')
-url="http://pwmt.org/projects/jumanji"
+pkgdesc="A highly customizable and functional web browser."
+arch=('x86_64' 'i686')
+url="https://pwmt.org/projects/jumanji"
license=('custom')
-depends=('girara' 'webkitgtk' 'libsoup>=2.36.1' 'sqlite3')
+depends=('girara' 'webkitgtk')
makedepends=('git')
-conflicts=('jumanji')
-provides=('jumanji')
-source=('jumanji::git+https://git.pwmt.org/pwmt/jumanji.git#branch=develop')
-md5sums=('SKIP')
-_repo=jumanji
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://git.pwmt.org/pwmt/${_pkgname}")
+sha256sums=('SKIP')
-build() {
- cd "$srcdir/$_repo"
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ cd ${_pkgname}
CFLAGS+=" -O0" make
}
package() {
- cd "$srcdir/$_repo"
-
- make DESTDIR="$pkgdir/" install
- install -D -m664 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-
-pkgver() {
- cd "$srcdir/$_repo"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
+ install -Dm664 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: