summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRONTheCookie2019-04-11 13:22:26 +0300
committerRONTheCookie2019-04-11 13:22:26 +0300
commit44d10663a78eb27d07ba88cdf3fb92b5c1b06ebd (patch)
treec762a2396a6d5203139b3ad321ed749d3ee4144c /PKGBUILD
downloadaur-44d10663a78eb27d07ba88cdf3fb92b5c1b06ebd.tar.gz
Inital Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e78ea6882c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ron B.S <ronthecookie0101 on gmail --OR-- me AT ronthecookie DOT me
+pkgname=jumpcutter-git
+pkgver=r18.df41c43
+pkgrel=1
+pkgdesc="Automatically edits videos. Explanation here: https://www.youtube.com/watch?v=DQ8orIurGxw"
+arch=('any')
+url="https://github.com/carykh/jumpcutter"
+license=('MIT')
+depends=('ffmpeg' 'python-pillow' 'python-audiotsm' 'python-scipy' 'python-numpy' 'python')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/carykh/jumpcutter.git" '0001-Add-shebang-line.patch')
+sha256sums=('SKIP'
+ '33c22ce87b48e0d08081da6543f7f7610fcae4240b95d91e285a49339e601ffb')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+prepare() {
+ cd "$srcdir/$pkgname"
+ git am < $srcdir/0001-Add-shebang-line.patch
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 jumpcutter.py "$pkgdir"/usr/bin/jumpcutter
+}