summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgoekce2023-10-17 15:01:51 +0200
committergoekce2023-10-17 15:01:51 +0200
commit9b5fbc648cc3fc9d9bb24b9affb9675274144d43 (patch)
tree95ed771cb31e3eb15b000dc1798e2f3daaca5927 /PKGBUILD
parent620c11d2ac9dfe5842294ededd02d388c1c169af (diff)
downloadaur-9b5fbc648cc3fc9d9bb24b9affb9675274144d43.tar.gz
update to 0.9.1, apply formatting
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 37 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40285ec7afa5..b9474ee9330d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: leuko <leuko_aydos_de>
+# Maintainer: Gökçe Aydos <aur2022_aydos_de>
pkgname=jupyter-nbgrader
_realm=jupyter
-_name=${pkgname#$_realm-}
-pkgver=0.8.1
+_name=${pkgname#"$_realm"-}
+pkgver=0.9.1
pkgrel=1
pkgdesc="A system for assigning and grading notebooks"
arch=(any)
@@ -11,41 +11,58 @@ url=https://github.com/$_realm/$_name
license=(BSD)
depends=(
python
- python-setuptools
- python-sqlalchemy
- python-dateutil
- jupyter-notebook
- jupyter-nbconvert
- python-requests
- python-jsonschema
python-alembic
- python-rapidfuzz
+ python-ipywidgets
python-jinja
- python-markupsafe
+ python-jsonschema
python-jupyter_client
jupyter-server
- python-qtconsole
- python-ipywidgets
+ python-jupyterlab-server
jupyter-nbclient
- python-traitlets
+ jupyter-nbconvert
+ jupyter-notebook
+ python-dateutil
+ python-rapidfuzz
+ python-requests
+ python-sqlalchemy
+ python-pyaml
+
+ # Additional optional deps from jsonschema probably due to https://github.com/jupyter/jupyter_events/blob/9b99f6718a3bb2686aab51e17f5c7ee276baf316/pyproject.toml#L31C4-L33C112
+ python-fqdn
+ python-rfc3986-validator
+ python-rfc3339-validator
+ python-webcolors
+ python-uri-template
+ python-jsonpointer
+ python-isoduration
+
+ # Others
+ python-types-python-dateutil
+ python-terminado
+ python-debugpy
+ jupyterlab
+ jupyter-lsp
+ npm # used by jlpm
+
)
makedepends=(
- jupyterlab-hatch-jupyter-builder
+ python-hatch-jupyter-builder
python-build
python-installer
python-wheel
)
source=(
- https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz
+ https://files.pythonhosted.org/packages/source/"${_name::1}/$_name/$_name-$pkgver".tar.gz
)
-sha256sums=('af9303537687c8326591aaa996970a3b158f6bc065da3a4b292b9060e1edee71')
+sha256sums=(88e3718fb4e6f75dd0b90afea3c5ad0abf14fd23ead4ce7a5c2be5eb6fa327d2)
build() {
- cd nbgrader-$pkgver
+ cd nbgrader-"$pkgver" || exit
python -m build --wheel --no-isolation
}
package() {
- cd nbgrader-$pkgver
+ cd nbgrader-"$pkgver" || exit
python -m installer --destdir="$pkgdir" dist/*.whl
+ mv "$pkgdir"/usr/etc "$pkgdir"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}