summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIyán Méndez Veiga2019-06-27 20:41:10 +0200
committerIyán Méndez Veiga2019-06-27 20:41:10 +0200
commitb6f92b014b2156435c5a6123e1b17cd4656f1678 (patch)
tree9a9e4270d774e1e0fa31d30e9b9ba2c92891ab88 /PKGBUILD
parentbc7161a2e6f932399bd28c2d2d430f268251b506 (diff)
downloadaur-b6f92b014b2156435c5a6123e1b17cd4656f1678.tar.gz
Update to 0.31.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 521971b1d325..a440a900500e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,21 @@
-# Maintainer: renyuneyun <renyuneyun@gmail.com>
+# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
+# Contributor: renyuneyun <renyuneyun (at) gmail (dot) com>
+
_name=octave_kernel
pkgname=jupyter-${_name}
-pkgver=0.19.9
-pkgrel=2
+pkgver=0.31.0
+pkgrel=1
pkgdesc="A Jupyter kernel for Octave"
arch=('any')
url="https://github.com/Calysto/octave_kernel"
license=('BSD')
-depends=(
- 'jupyter-notebook'
- 'octave'
- 'jupyter-metakernel'
-)
+depends=('jupyter' 'jupyter-metakernel' 'jupyter-notebook' 'octave')
makedepends=('python-pip')
-optdepends=(
- 'gnuplot: for making plots'
-)
-options=()
-source=("https://pypi.python.org/packages/be/54/3a3c1428923a01b7b12425db808ffc0b40d707f2bd5a67f530f383f71195/octave_kernel-0.19.9-py2.py3-none-any.whl")
-md5sums=('47f81acb864a6c0ebdfbc91fadcb8c11')
+optdepends=('gnuplot: for making plots' 'jupyterlab: JupyterLab computational environment')
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/${_name}/${_name/-/_}-${pkgver}-py3-none-any.whl")
+sha256sums=('3bec024eed29105af73f6110bb12c8aa6146415743606c91f1b91547a35f4b7c')
package() {
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
-}
-
-# vim:set ts=2 sw=2 et:
+} \ No newline at end of file