summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrenyuneyun2016-09-30 22:25:21 +0100
committerrenyuneyun2016-09-30 22:25:21 +0100
commitce80a2098dda4d45550cfba385fa226aa54fe11a (patch)
tree375e33d252995515d634734d86628d779b99cfb1 /PKGBUILD
downloadaur-ce80a2098dda4d45550cfba385fa226aa54fe11a.tar.gz
initial commit with pkver=0.7.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e71697760e6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: renyuneyun <renyuneyun@gmail.com>
+_name=octave_kernel
+pkgname=jupyter-${_name}
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="A Jupyter kernel for Octave"
+arch=('any')
+url="https://github.com/Calysto/octave_kernel"
+license=('BSD')
+depends=(
+ 'jupyter-notebook'
+ 'octave'
+ 'python-oct2py'
+)
+makedepends=('python-setuptools')
+options=()
+source=("https://github.com/Calysto/octave_kernel/archive/v$pkgver.tar.gz")
+md5sums=('f78644bd8a9f45ad293b1c27a855222d')
+
+
+package() {
+ cd "$srcdir/${_name}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: