summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRenato Candido2017-07-21 22:00:59 -0300
committerRenato Candido2017-07-21 22:00:59 -0300
commit85849a96905cb1120d1bf01d4a74d31a2072cab6 (patch)
treec5366f9d1e3103489396b633a04084877f671f30 /PKGBUILD
downloadaur-85849a96905cb1120d1bf01d4a74d31a2072cab6.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eb13c53e94f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Renato Candido <renatocan@gmail.com>
+
+pkgname=jupyterthemes
+pkgver=0.17.3
+pkgrel=1
+pkgdesc="Select and install a Jupyter notebook theme"
+url="https://github.com/dunovank/jupyter-themes"
+depends=('python' 'python-matplotlib' 'jupyter-notebook' 'python-lesscpy')
+makedepends=('python3' )
+license=('MIT')
+arch=('any')
+source=('https://pypi.python.org/packages/99/c6/0c5e58bdc3a3f1042e88bb35435e04d346c862745ec2ffe2004bd030ebb3/jupyterthemes-0.17.3.tar.gz')
+md5sums=('01cbc565f6b2170afd1a5151b57274b8')
+
+build() {
+ cd $srcdir/jupyterthemes-0.17.3
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/jupyterthemes-0.17.3
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+md5sums=('01cbc565f6b2170afd1a5151b57274b8')