summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-10-15 23:58:16 +0200
committerhaawda2017-10-15 23:58:16 +0200
commitd1b27eec638db93435676f02cbd6ffa6a1e6879e (patch)
tree9de5cddbf1539792dc8f085d8bb764dff55c79f8 /PKGBUILD
parentd0d3b9a8aa0b0680536ce689514ed594603a1430 (diff)
downloadaur-d1b27eec638db93435676f02cbd6ffa6a1e6879e.tar.gz
update with fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbc236ac92bb..3f9bf3c8a765 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=just-git
-pkgver=0.3.1.326
+pkgver=0.3.3.334
pkgrel=1
pkgdesc="Just a command runner, like make."
arch=('x86_64' 'i686')
@@ -14,16 +14,16 @@ source=(git+https://github.com/casey/just.git)
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- echo $(git describe|tr -d v).$(git rev-list --count HEAD)
+ cd ${pkgname%-git}
+ echo $(git describe --tags|tr - .|tr -d v).$(git rev-list --count HEAD)
}
build() {
- cd $pkgname
+ cd ${pkgname%-git}
cargo build --release
}
package() {
- cd $pkgname
- install -D -m755 "$srcdir/$pkgname/target/release/just" "$pkgdir/usr/bin/just"
+ cd ${pkgname%-git}
+ install -Dm755 "$srcdir"/${pkgname%-git}/target/release/just "$pkgdir"/usr/bin/just
}