summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Thies2023-06-02 23:00:00 +0200
committerMichael Thies2023-06-02 23:47:23 +0200
commit232f1ff5d4adbc5c3378b87edd1ab11865e1a792 (patch)
tree1044dc8032e71e2c7676838ee4d40082fa8afe8d /PKGBUILD
parentca4fc32c20d91e503245433091a167440037892b (diff)
downloadaur-232f1ff5d4adbc5c3378b87edd1ab11865e1a792.tar.gz
Change to native dependencies (LOCALBASE bootstrapping)
For now, we'll build libgit2 from source, due to a regression in the current version (shipped with Arch), which will be fixed in the next release.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae9a2ac77bcf..7575f271f75a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgdesc="A generic build system supporting multi-repository builds"
arch=('x86_64')
url="https://github.com/just-buildsystem/justbuild"
license=('Apache')
-depends=('python')
-makedepends=('clang' 'binutils' 'wget' 'pandoc')
+depends=('fmt' 'openssl' 'zlib' 're2' 'c-ares' 'grpc' 'abseil-cpp' 'curl' 'python' 'protobuf')
+makedepends=('clang' 'binutils' 'wget' 'cli11' 'microsoft-gsl' 'nlohmann-json' 'pandoc')
conflicts=('just' 'just-git' 'just-js')
source=("justbuild-${pkgver}.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v${pkgver}.tar.gz")
sha256sums=('75b7d92d233250fa9751542cf5020c10b20e178f898b3fe1294fc9013b4ad5fe')
@@ -17,16 +17,20 @@ build() {
cd "${srcdir}/justbuild-${pkgver}"
# Clean build directory from potential previous run
# The bootstrap script expects the build directory to be clean; esp. src, dep_includes and deps must not be present
- [[ -d "${srcdir}/build/dep_includes" ]] && rm -rf "${srcdir}/build"
+ [[ -d "${srcdir}/build/src" ]] && rm -rf "${srcdir}/build"
mkdir -p "${srcdir}/build"
# Bootstrap just
- env JUST_BUILD_CONF='{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar"}' python3 ./bin/bootstrap.py . "${srcdir}/build"
+ env JUST_BUILD_CONF='{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar"}'\
+ PACKAGE=YES\
+ LOCALBASE=/usr\
+ NON_LOCAL_DEPS='["bazel_remote_apis", "google_apis", "com_github_libgit2_libgit2"]'\
+ python3 ./bin/bootstrap.py . ${srcdir}/build
# Build compiled just-mr
- python ./bin/just-mr.py --just "../build/out/bin/just" --always-file install 'installed just-mr' --output-dir ../build/out -D '{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar"}'
+ ../build/out/bin/just install 'installed just-mr' -c ../build/build-conf.json -C ../build/repo-conf.json --output-dir ../build/out
- # convert man pages from orgmode to man
+ # convert man pages from Markdown to man
find "${srcdir}/justbuild-${pkgver}/share/man" -name "*.md" -exec sh -c 'pandoc --standalone --to man -o "${0%.md}.man" "${0}"' {} \;
}