summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Thies2023-02-06 21:37:02 +0100
committerMichael Thies2023-02-06 21:37:02 +0100
commit5660a8f4cad4f9af73bcae2141dec14c10cf8258 (patch)
tree788f3798ce7aec7b87f2a34f08bca494e973dd06 /PKGBUILD
parentd7ad0f8fc23c1c751628cc7e4585c11b451573aa (diff)
downloadaur-5660a8f4cad4f9af73bcae2141dec14c10cf8258.tar.gz
Add just-import-git executable, bash completions and man pages; bump to rel 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8907747d3986..31fab88c1c6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=justbuild
pkgver='1.0.0'
-pkgrel=1
+pkgrel=2
pkgdesc="A generic build system supporting multi-repository builds"
arch=('x86_64')
url="https://github.com/just-buildsystem/justbuild"
license=('Apache')
depends=('python')
-makedepends=('clang' 'binutils' 'wget')
+makedepends=('clang' 'binutils' 'wget' 'emacs')
conflicts=('just' 'just-git' 'just-js')
source=("justbuild-${pkgver}.tar.gz::https://github.com/just-buildsystem/justbuild/archive/v${pkgver}.tar.gz"
"boringssl-no-Werror.patch")
@@ -28,9 +28,23 @@ build() {
mkdir -p "${srcdir}/build"
env JUST_BUILD_CONF='{"COMPILER_FAMILY": "clang", "CC": "/usr/bin/clang", "CXX": "/usr/bin/clang++", "AR": "/usr/bin/ar"}' python3 ./bin/bootstrap.py . "${srcdir}/build"
+
+ # convert man pages from orgmode to man
+ find "${srcdir}/justbuild-${pkgver}/share/man" -name "*.org" -exec emacs {} --batch --eval "(require 'ox-man)" -f org-man-export-to-man --kill \;
}
package() {
install -m 755 -Dt "${pkgdir}/usr/bin" "${srcdir}/build/out/bin/just"
install -m 755 -DT "${srcdir}/justbuild-${pkgver}/bin/just-mr.py" "${pkgdir}/usr/bin/just-mr"
+ install -m 755 -DT "${srcdir}/justbuild-${pkgver}/bin/just-import-git.py" "${pkgdir}/usr/bin/just-import-git"
+
+ # bash completion
+ mkdir -p "${pkgdir}"/usr/share/bash-completion/completions
+ install -m 0644 "${srcdir}/justbuild-${pkgver}"/share/just_complete.bash "${pkgdir}"/usr/share/bash-completion/completions/just
+
+ # man
+ mkdir -p "${pkgdir}"/usr/share/man/{man1,man5}
+ install -m 0644 -t "${pkgdir}"/usr/share/man/man1 "${srcdir}/justbuild-${pkgver}"/share/man/*.1.man
+ install -m 0644 -t "${pkgdir}"/usr/share/man/man5 "${srcdir}/justbuild-${pkgver}"/share/man/*.5.man
+ find "${pkgdir}"/usr/share/man -name "*.man" -exec sh -c 'mv "$1" "${1%.man}"' _ {} \;
}