summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-04-27 23:36:03 +0800
committerYen Chi Hsuan2017-04-27 23:36:03 +0800
commit578dffba8674eaffbe991d629207543fae6d7ed0 (patch)
tree87602fa1df9fccfb54ee32625b6eecdae39e84bd /PKGBUILD
parent18487666801d9e55ee64f92579d584f3ddb7f557 (diff)
downloadaur-jython-hg.tar.gz
Bump to r8074.fc946dea9c0f
Run tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3480c1692c14..94bf042a75e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Richard Murri <admin@richardmurri.com>
_pkgname=jython
pkgname=$_pkgname-hg
-pkgver=r7962.91083509a11c
+pkgver=r8074.fc946dea9c0f
pkgrel=1
pkgdesc="An implementation of the Python language written in Java"
arch=('any')
@@ -39,6 +39,12 @@ build() {
ant || ant
}
+check() {
+ cd "$srcdir/$_pkgname"
+
+ ant test
+}
+
package() {
install -m755 -D -d "$pkgdir/opt/"