summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-09-07 02:45:22 +0800
committerYen Chi Hsuan2016-09-07 02:45:22 +0800
commit18487666801d9e55ee64f92579d584f3ddb7f557 (patch)
tree88543fd23298a2e8150155dedfcc303559124d19 /PKGBUILD
parent554fb78f2a5ba4c5802920bfe5dd802e351a14ec (diff)
downloadaur-18487666801d9e55ee64f92579d584f3ddb7f557.tar.gz
Bump to r7962.91083509a11c
Drop a landed patch. See http://bugs.jython.org/issue2481
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bfedf181b4b..3480c1692c14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,45 +5,38 @@
# Contributor: Richard Murri <admin@richardmurri.com>
_pkgname=jython
pkgname=$_pkgname-hg
-pkgver=r7918+.87534ec6252a+
+pkgver=r7962.91083509a11c
pkgrel=1
pkgdesc="An implementation of the Python language written in Java"
arch=('any')
url="http://www.jython.org/"
license=('PSF' 'APACHE' 'custom')
-# Jython requires jdk7 for correct building
-# TODO: Find a way to accept both jdk7 and jdk7-openjdk
-depends=('jdk7-openjdk' 'bash' 'python2')
-makedepends=('apache-ant')
+depends=('java-runtime' 'bash' 'python2')
+makedepends=('apache-ant' 'mercurial')
backup=('opt/jython/registry')
options=('!emptydirs')
install='jython.install'
source=("hg+https://hg.python.org/jython/"
'README.ArchLinux'
- 'jython.sh'
- 'issue2481.patch')
+ 'jython.sh')
provides=('jython')
conflicts=('jython')
md5sums=('SKIP'
'0a2e265af61c7d695e13b605dc180553'
- 'c08ade059dae86b015f39842ceb465cf'
- 'a9f1dc09c8fdb2f1b3a0a2b9793a44df')
+ 'c08ade059dae86b015f39842ceb465cf')
pkgver() {
cd "$srcdir/$_pkgname"
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
-prepare() {
- cd "$srcdir/$_pkgname"
- patch -i ../issue2481.patch -Np1
-}
-
build() {
cd "$srcdir/$_pkgname"
- JAVA_HOME="/usr/lib/jvm/java-7-openjdk" ant
+ # ANTLR 3 causes non-fatal errors with Java 8, so just try again
+ # http://stackoverflow.com/a/22367682/3786245
+ ant || ant
}
package() {