summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-02-27 11:16:54 +0100
committerAlexander F. Rødseth2019-02-27 11:16:54 +0100
commit7f2a48295ea54c19892e3f7e7d364dbb5ca9a04f (patch)
treebb66108e80de3317a5b1dc290be9b8a033006695 /PKGBUILD
downloadaur-7f2a48295ea54c19892e3f7e7d364dbb5ca9a04f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8383022142d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=k3s-git
+pkgver=r1.7d1baa9
+pkgrel=1
+pkgdesc='Lightweight Kubernetes'
+arch=(x86_64)
+url='https://github.com/rancher/k3s'
+license=(MIT)
+makedepends=(docker git go)
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ git clone --depth=1 "git://github.com/rancher/k3s" $pkgname 2>/dev/null || (cd $pkgname; git fetch origin; git reset --hard origin/master)
+}
+
+build() {
+ make -C $pkgname
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C $pkgname install
+ install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: