summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2023-02-13 00:50:16 +0000
committerJoão Figueiredo2023-02-13 00:50:16 +0000
commitf2378c70bd6218624889c5c855e160c60a9329c7 (patch)
treec8235777a31d71c1a9ca487d6f2538e7bc533999 /PKGBUILD
parent18eb6751db0e2ee036e03c51b09ec7aa36cf37b0 (diff)
downloadaur-f2378c70bd6218624889c5c855e160c60a9329c7.tar.gz
Migrate to Qt6 (this time for real!)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08c768c00d0e..a70495dc3d33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,17 +11,17 @@ pkgdesc="Core components for the KDE's Activities"
url='https://community.kde.org/Frameworks'
license=(LGPL)
depends=(kcoreaddons-git kconfig-git kwindowsystem-git)
-makedepends=(git extra-cmake-modules-git boost doxygen qt5-tools qt5-declarative)
+makedepends=(git extra-cmake-modules-git boost doxygen qt6-tools qt6-declarative)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-optdepends=('qt5-declarative: QML bindings')
-groups=(kf5-git)
+optdepends=('qt6-declarative: QML bindings')
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}