summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoReleaser2024-03-08 13:13:44 +0000
committerGoReleaser2024-03-08 13:13:44 +0000
commit3a1a5cad4fdfa0108f659d86f7c3ffb8a4297a0f (patch)
tree29ecf038c570edb7c9beb40ed638fbe9843dfe2c /PKGBUILD
parent704558f09335c368b4424c76b96d345d4c17d860 (diff)
downloadaur-3a1a5cad4fdfa0108f659d86f7c3ffb8a4297a0f.tar.gz
Updated to version v5.0.2 release 1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af29259415e1..e9e8d305c330 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dirk Wilden <dirk.wilden@device-insight.com>
pkgname=kafkactl
-pkgver=5.0.1
+pkgver=5.0.2
pkgrel=1
pkgdesc="Command Line Tool for managing Apache Kafka"
url="https://github.com/deviceinsight/kafkactl/"
@@ -16,13 +16,14 @@ source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/deviceinsight/kafkactl/archive/v${pkgver}.tar.gz"
)
sha256sums=(
- 6b0e6c98035c797fe5c76e6a9f675173cd422a6dfe8ee51b09f33ff57fa7dd57
+ af978d336a7e12f9211b75ca57b9bc0507fd35943f7c49b1da82da86236c204a
)
build() {
cd "${pkgname}-${pkgver}"
export CGO_LDFLAGS="$LDFLAGS"
- go build -ldflags "-linkmode=external -X github.com/deviceinsight/kafkactl/cmd.Version=v${pkgver}" -o ${pkgname} .
+ export module=$(go list -m)
+ go build -ldflags "-linkmode=external -X ${module}/cmd.Version=v${pkgver}" -o ${pkgname} .
}
check() {