summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2018-09-25 21:48:36 +0200
committerEmmanuel Gil Peyrot2018-09-25 21:48:36 +0200
commit4ecc3f19d0b8245049184855e3f408b8bc2a726b (patch)
tree1938e56063c43711cc0a7f49f782977698886c8b /PKGBUILD
parent23915f8233f09dd865e280e91494593ae25d0cd2 (diff)
downloadaur-4ecc3f19d0b8245049184855e3f408b8bc2a726b.tar.gz
Add extra-cmake-modules to the makedepends, and install in /usr.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc9cf6c2f126..f8d79c90580f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
pkgname=kaidan-git
-pkgver=r235.b8190ef
+pkgver=r493.ab2c4ab
pkgrel=1
pkgdesc="Simple and user-friendly Jabber/XMPP client for every device"
arch=('i686' 'x86_64')
url="https://github.com/KaidanIM/Kaidan"
license=('GPL3')
depends=('qt5-base' 'qt5-declarative' 'qt5-quickcontrols2' 'kirigami2' 'gloox')
-makedepends=('git' 'cmake')
+makedepends=('git' 'cmake' 'extra-cmake-modules')
source=("kaidan::git+https://github.com/KaidanIM/Kaidan")
sha256sums=('SKIP')
conflicts=('kaidan')
@@ -26,7 +26,10 @@ prepare() {
build() {
cd "$srcdir/kaidan/build"
- cmake -DCMAKE_BUILD_TYPE=Release -DI18N=ON ..
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DI18N=ON
make
}