summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgustawho2021-05-13 20:07:39 -0600
committergustawho2021-05-13 20:07:39 -0600
commit9bc16781d644bcee5caa2a8b47d1ebc697a8fd89 (patch)
tree224774a11f9d572b1eb56d21a38ffc6f5ed9fb1e /PKGBUILD
parent46131698f66eb6d188fb0ebd5083510116d871c3 (diff)
downloadaur-9bc16781d644bcee5caa2a8b47d1ebc697a8fd89.tar.gz
PKGBUILD cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5aec29435697..9a8c5864c753 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=kalk-git
-pkgver=v0.2.r70.g09f5754
+pkgver=v21.05.r0.gb5247dd
pkgrel=1
pkgdesc="Kalk is a powerful cross-platfrom calculator application built with the Kirigami framework"
-arch=('x86_64')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://invent.kde.org/plasma-mobile/kalk"
license=('GPL3')
depends=('ki18n' 'kconfig' 'kcoreaddons' 'knotifications' 'kirigami2' 'kunitconversion'
@@ -24,10 +24,10 @@ pkgver() {
}
build() {
- cmake -B build -S "${pkgname%-git}" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
- cmake --build build --config Release
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- DESTDIR="${pkgdir}" cmake --install build --config Release
-}
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+} \ No newline at end of file