summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndre Schneider2022-11-28 00:53:43 +0100
committerAndre Schneider2022-11-28 00:53:43 +0100
commitff4217c73a6759216698f86542d022d1f2025dcd (patch)
tree781969657977e5d757aef8bf12fe3d60f266e995 /PKGBUILD
downloadaur-ff4217c73a6759216698f86542d022d1f2025dcd.tar.gz
Creates kalker-bin package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8829d4c549f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Andre Schneider <andre.schneider@outlook.at>
+
+pkgname=kalker-bin
+_pkgname=kalker
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Kalker/kalk is a calculator with math syntax that supports user-defined variables and functions, complex numbers, and estimation of derivatives and integrals"
+arch=('x86_64')
+url="https://kalker.xyz/"
+license=('MIT')
+provides=('kalker')
+conflicts=('kalker' 'kalker-git')
+options=(!strip)
+source=("$_pkgname::https://github.com/PaddiM8/kalker/releases/download/v$pkgver/$_pkgname-linux")
+sha256sums=('c8753ca3785a01cc059a6b1fd862d145ed454c908c0f05cda95bae0badaa3317')
+
+package() {
+ # Install binary and launch script
+ install -Dm755 -t "$pkgdir/usr/bin" "$srcdir/$_pkgname"
+}