summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2016-12-19 11:24:41 +0100
committerMichel Zou2016-12-19 11:24:41 +0100
commit4c236034f51502efe29e5100f529dadf4c0de640 (patch)
tree76fcbd348019a76a7db00a066e7abd2ae3a57d6c /PKGBUILD
downloadaur-4c236034f51502efe29e5100f529dadf4c0de640.tar.gz
0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42f2a3a2ee78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=kalliope
+pkgver=0.3.0
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Modular always-on voice controlled personal assistant designed for home automation"
+depends=(portaudio python2-speechrecognition python2-markupsafe python2-pyaudio python2-pythondialog python2-jinja python2-cffi python2-flask-restful python2-wikipedia python2-pygmail python2-twitter python2-ipaddress python2-wakeonlan python2-apscheduler python2-flask-testing python2-httpretty python2-requests)
+license=('MIT')
+url="https://github.com/kalliope-project/kalliope"
+source=("https://github.com/kalliope-project/kalliope/archive/v${pkgver}.tar.gz")
+sha256sums=('7ddea6e381917f4f8c9a9984d393c997dbc8345dd58a377f63337cb0739416dc')
+
+prepare() {
+ cd "$srcdir/kalliope-${pkgver}"
+ # https://github.com/kalliope-project/kalliope/pull/147
+ sed -i "s|requests==2.12.1|requests==2.12.4|g" setup.py
+}
+
+build()
+{
+ cd "$srcdir/kalliope-${pkgver}"
+ python2 setup.py build
+}
+
+package()
+{
+ cd "$srcdir/kalliope-${pkgver}"
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}