summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-11-25 19:59:23 +0100
committerMichel Zou2019-11-25 19:59:23 +0100
commit4f4a143fac7a2e87e18dd909d1992d6044096b81 (patch)
treec8640a35fb65c697a16503db45fee8e89554a817 /PKGBUILD
parent55d53f094d649209fe6438771169f33fe6217956 (diff)
downloadaur-4f4a143fac7a2e87e18dd909d1992d6044096b81.tar.gz
python-snowboy
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f38a7c989ec..a02e26a20ac7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgver=0.5.5
pkgrel=1
arch=('x86_64')
pkgdesc="Modular always-on voice controlled personal assistant designed for home automation"
-makedepends=('swig')
+makedepends=('python-snowboy')
depends=(portaudio python-markupsafe python-pyaudio python-pythondialog python-jinja python-cffi python-flask-restful python-ipaddress python-apscheduler python-flask-testing python-httpretty python-requests svox-pico-bin mplayer python-feedparser python-mock python-transitions python-gitpython python-pyalsaaudio python-soundfile python-sounddevice python-sox python-voicerss-tts python-paho-mqtt python-ansible python-cachingutil python-pip cblas python-gevent python-gtts python-sox python-speechrecognition python-configurationutil python-stateutil python-ruamel-yaml python-logging-tree python-classutils python-uiutil python-tableutil python-conversionutil python-openpyxl)
license=('MIT')
url="https://github.com/kalliope-project/kalliope"
@@ -21,19 +21,10 @@ build()
{
cd "$srcdir/kalliope-${pkgver}"
python setup.py build
-
- # rebuild snowboy
- SNOWBOY_VERSION=1.3.0
- curl -fSsLO https://github.com/Kitt-AI/snowboy/archive/v${SNOWBOY_VERSION}.tar.gz
- rm -rf snowboy-${SNOWBOY_VERSION}
- tar xzf v${SNOWBOY_VERSION}.tar.gz
- cd snowboy-${SNOWBOY_VERSION}/swig/Python
- sed -i "s|-lf77blas -lcblas -llapack -latlas|-lcblas|g" Makefile
- make
- python -c "import _snowboydetect; print('OK')"
- cd ../../..
+
+ # bundle snowboy
mkdir -p ./build/lib/kalliope/trigger/snowboy/x86_64/python38/
- cp ./snowboy-${SNOWBOY_VERSION}/swig/Python/_snowboydetect.so ./build/lib/kalliope/trigger/snowboy/x86_64/python38/
+ cp /usr/lib/python3.8/site-packages/snowboy/_snowboydetect.so ./build/lib/kalliope/trigger/snowboy/x86_64/python38/
}
package()