summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2017-03-26 11:09:01 +0200
committerMichel Zou2017-03-26 11:09:01 +0200
commite2c24c2629cbc5d1ad050894f2b01d97aacdfb00 (patch)
tree149d5adb0885c08a10fef2a8bff04fe2c21f5878 /PKGBUILD
parent7fc7210c7fc637c4ecc7cd1833a5aabc42c5b9aa (diff)
downloadaur-e2c24c2629cbc5d1ad050894f2b01d97aacdfb00.tar.gz
0.4.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61de58f49334..80c97685e16a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=kalliope
-pkgver=0.4.2
+pkgver=0.4.3
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Modular always-on voice controlled personal assistant designed for home automation"
@@ -7,17 +7,11 @@ depends=(portaudio python2-speechrecognition python2-markupsafe python2-pyaudio
license=('MIT')
url="https://github.com/kalliope-project/kalliope"
source=("https://github.com/kalliope-project/kalliope/archive/v${pkgver}.tar.gz")
-sha256sums=('fda4089fd22568d197049d8aa8789ec62db035e6b990f498bc922a6c1c767a2b')
-
+sha256sums=('98cfda9c7ac0ec19c00e2d2f55a36c060172059411320783187ca7e5b8832f5c')
prepare() {
cd "$srcdir/kalliope-${pkgver}"
- # https://github.com/kalliope-project/kalliope/pull/220
- sed -i "s|requests==2.12.4|requests>=2.12.4|g" setup.py
- sed -i "s|flask==0.11.1|flask>=0.11.1|g" setup.py
- sed -i "s|ipaddress==1.0.17|ipaddress>=1.0.17|g" setup.py
- sed -i "s|jinja2==2.8|jinja2>=2.8|g" setup.py
- sed -i "s|ansible==2.2.0.0|ansible>=2.2.0.0|g" setup.py
+ sed -i "s|jinja2>=2.8,<2.9|jinja2>=2.8|g" setup.py
}
build()