summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-11-24 22:36:24 +0100
committerMichel Zou2019-11-24 22:36:24 +0100
commiteee572ea0dc156d2a4b0bfc18c48af0171fd5c90 (patch)
tree25f36629bbe2bdef53f925558bf67ebd7133d828 /PKGBUILD
parent0857ee66f791a81dd23139128243c289566e4731 (diff)
downloadaur-eee572ea0dc156d2a4b0bfc18c48af0171fd5c90.tar.gz
0.5.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7173e434e9df..4ffc722f0158 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
pkgname=kalliope
-pkgver=0.5.0
+pkgver=0.5.5
pkgrel=1
arch=('x86_64')
pkgdesc="Modular always-on voice controlled personal assistant designed for home automation"
-makedepends=(swig wget)
-depends=(portaudio python-speechrecognition python-markupsafe python-pyaudio python-pythondialog python-jinja python-cffi python-flask-restful python-ipaddress python-apscheduler python-flask-testing python-httpretty python-requests svox-pico-bin mplayer python-feedparser python-mock python-transitions python-gitpython python-pyalsaaudio python-rpi.gpio python-soundfile python-sounddevice python-sox python-voicerss-tts python-paho-mqtt python-flask_cors python-ansible python-cachingutil python-pip cblas)
+# makedepends=('swig' 'wget')
+depends=(portaudio python-markupsafe python-pyaudio python-pythondialog python-jinja python-cffi python-flask-restful python-ipaddress python-apscheduler python-flask-testing python-httpretty python-requests svox-pico-bin mplayer python-feedparser python-mock python-transitions python-gitpython python-pyalsaaudio python-soundfile python-sounddevice python-sox python-voicerss-tts python-paho-mqtt python-ansible python-cachingutil python-pip cblas python-gevent python-gtts python-sox python-speechrecognition python-configurationutil python-stateutil python-ruamel-yaml python-logging-tree python-classutils python-uiutil python-tableutil python-conversionutil python-openpyxl)
license=('MIT')
url="https://github.com/kalliope-project/kalliope"
source=("https://github.com/kalliope-project/kalliope/archive/v${pkgver}.tar.gz")
-sha256sums=('e4e1930a6cbacd4b6c28f41a4c7a900c25deb0951c9de8716becffef4e329fe0')
+sha256sums=('3b2dbee3e380d3942491684a5c6dd00ab173dda3472faf71f08e138c8946cfbd')
prepare()
{
cd "$srcdir/kalliope-${pkgver}"
- sed -i "s|jinja2>=2.8,<=2.9.6|jinja2>=2.8|g" setup.py
- sed -i "s|ansible>=2.3,<2.4|ansible>=2.3|g" setup.py
+ sed -i "s|ansible>=2.8.1,<2.9|ansible>=2.8|g" setup.py
# rebuild snowboy
- SNOWBOY_VERSION=1.2.0
- wget -c https://github.com/Kitt-AI/snowboy/archive/v${SNOWBOY_VERSION}.tar.gz
- rm -rf snowboy-${SNOWBOY_VERSION}
- tar xzf v${SNOWBOY_VERSION}.tar.gz
- cd snowboy-${SNOWBOY_VERSION}/swig/Python
- sed -i "s|-lf77blas -lcblas -llapack_atlas -latlas|-lcblas|g" Makefile
- make
- python -c "import _snowboydetect; print('OK')"
- cd ../../..
- cp ./snowboy-1.2.0/swig/Python/_snowboydetect.so ./kalliope/trigger/snowboy/x86_64/python36/
+# SNOWBOY_VERSION=1.2.0
+# wget -c https://github.com/Kitt-AI/snowboy/archive/v${SNOWBOY_VERSION}.tar.gz
+# rm -rf snowboy-${SNOWBOY_VERSION}
+# tar xzf v${SNOWBOY_VERSION}.tar.gz
+# cd snowboy-${SNOWBOY_VERSION}/swig/Python
+# sed -i "s|-lf77blas -lcblas -llapack_atlas -latlas|-lcblas|g" Makefile
+# make
+# python -c "import _snowboydetect; print('OK')"
+# cd ../../..
+# cp ./snowboy-1.2.0/swig/Python/_snowboydetect.so ./kalliope/trigger/snowboy/x86_64/python36/
}
@@ -39,5 +38,5 @@ build()
package()
{
cd "$srcdir/kalliope-${pkgver}"
- python setup.py install --root=${pkgdir} --optimize=1
+ python setup.py install --root="${pkgdir}" --optimize=1
}