summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThulinma2021-06-27 14:41:46 +0200
committerThulinma2021-06-27 14:41:46 +0200
commit9bf0e26b05412f583ad13fe623b76ecef8236e95 (patch)
tree45f64a70055635e4e256172ae2f5e26e738fb037 /PKGBUILD
parent95986c3294007857765e80b1a86506a56d21ec8f (diff)
downloadaur-9bf0e26b05412f583ad13fe623b76ecef8236e95.tar.gz
Switched to Thulinma's branch of kalu, updated to 4.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d74f6601763..3f5d02d80410 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
+# Maintainer: Thulinma
# Maintainer: jjacky
pkgname=kalu
-pkgver=4.3.0
+pkgver=4.4.0
pkgrel=1
pkgdesc="Upgrade notifier w/ AUR support, watched (AUR) packages, news"
arch=('i686' 'x86_64')
-url="https://jjacky.com/kalu"
+url="https://github.com/Thulinma/kalu"
license=('GPL3+')
-depends=('dbus' 'polkit' 'gtk3' 'pacman>=5.1' 'pacman<5.2' 'curl' 'libnotify'
- 'notification-daemon')
-makedepends=('perl' 'groff')
-source=(https://jjacky.com/$pkgname/$pkgname-$pkgver.tar.xz)
+depends=('dbus' 'polkit' 'gtk3' 'pacman>=6.0' 'pacman<6.1' 'curl' 'libnotify' 'notification-daemon')
+makedepends=('perl' 'groff' 'git' 'automake')
+source=(git+https://github.com/Thulinma/kalu.git)
install=kalu.install
-sha1sums=('4e9fc8b311077d3720af8619de04c917c01acbfb')
+sha1sums=('SKIP')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" install
chmod 750 "$pkgdir/usr/share/polkit-1/rules.d"
chown 0:102 "$pkgdir/usr/share/polkit-1/rules.d"
}
-# vim:set ts=2 sw=2 et: