summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhinoceros2015-06-09 08:29:15 +1000
committerRhinoceros2015-06-09 08:29:15 +1000
commit2da04a4a1f74002deacb57df37220abe036f3142 (patch)
tree08f655e6552061abef4fad934c177371cc2e3b9b /PKGBUILD
downloadaur-2da04a4a1f74002deacb57df37220abe036f3142.tar.gz
Initial commit of 3.0.0-1
* Modified version of kalu, with --enable-status-notifier for KDE, and corresponding dependency on statusnotifier.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05ea8d1dfe8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: jjacky
+
+pkgname=kalu-kde
+_pkgname_orig=kalu
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Upgrade notifier w/ AUR support, watched (AUR) packages, news; supports autohide in KDE's panel"
+arch=('i686' 'x86_64')
+url="http://jjacky.com/kalu"
+license=('GPL3+')
+depends=('dbus' 'polkit' 'gtk3' 'pacman>=4.2' 'pacman<4.3' 'curl' 'libnotify'
+ 'notification-daemon' 'statusnotifier')
+makedepends=('perl' 'groff')
+source=(http://jjacky.com/$_pkgname_orig/$_pkgname_orig-$pkgver.tar.gz)
+install=kalu.install
+sha1sums=('26ef0abb23d4590c3b851d6f61f4063e84e181f3')
+provides=($_pkgname_orig)
+conflicts=($_pkgname_orig)
+
+build() {
+ cd "$srcdir/$_pkgname_orig-$pkgver"
+ ./configure --prefix=/usr --enable-status-notifier
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname_orig-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ chmod 700 "$pkgdir/usr/share/polkit-1/rules.d"
+ chown 102 "$pkgdir/usr/share/polkit-1/rules.d"
+}
+
+# vim:set ts=2 sw=2 et: