summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbeelzy2019-07-07 03:45:39 +0200
committerbeelzy2019-07-07 03:45:39 +0200
commit1dfb645bf1ae89e64217b4b75b954a81313d5dd5 (patch)
tree644e349601dd44399cf92518201bb13f865bbf3d /PKGBUILD
downloadaur-1dfb645bf1ae89e64217b4b75b954a81313d5dd5.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec21c247a7a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: beelzy
+pkgname=kame-tools-git
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="A tool for bundling 3DS theme files"
+arch=('i686' 'x86_64')
+url="https://gitlab.com/beelzy/kame-tools"
+license=('MIT')
+makedepends=('git' 'zip')
+depends=('gcc-libs')
+
+_gitroot='https://gitlab.com/beelzy/kame-tools.git'
+_gitname='kame-tools'
+
+source=("${_gitname}::git+${_gitroot}"
+ "buildtools::git+https://github.com/Steveice10/buildtools.git")
+sha256sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd "$srcdir/$_gitname"
+ git submodule init
+ git config submodule.buildtools.url "$srcdir/buildtools"
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ make BUILD_FLAGS="$LDFLAGS"
+}
+
+package() {
+ install -D "$srcdir/$_gitname/output/linux-$CARCH/kame-tools" "$pkgdir/usr/bin/kame-tools"
+ install -Dm644 "$srcdir/$_gitname/LICENSE.txt" "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}